Múltiples vulnerabilidades en Netscape 8.0

Compartir

Netscape Browser 8.0 y versiones anteriores, son afectados por múltiples vulnerabilidades originalmente detectadas en Mozilla y Mozilla Firefox, las cuáles son explotables en forma remota. Para resolver las mismas, Netscape Communications ha publicado la versión 8.0.1 de su navegador.

La mayoría de estas vulnerabilidades pueden ser utilizadas para la ejecución remota de código, o para eludir las políticas de acceso y escalar privilegios. También habilitan la ejecución de scripts (archivos de comandos), en ventanas pertenecientes a diferentes dominios (cross-site scripting).

Un atacante puede obtener ventajas de estos fallos para ejecutar código en el equipo afectado, con los privilegios del usuario actualmente conectado.

Estas vulnerabilidades también permiten a un atacante robar cookies, o acceder a otra información confidencial.


* Ejecución vía javascript (IconURL)

Referencia: Mozilla Foundation Security Advisory 2005-42

Dos vulnerabilidades encontradas en Mozilla que afectan a Netscape Browser, pueden ser combinadas para permitir que un atacante ejecute código de forma arbitraria.

La vulnerabilidad en la ventana de diálogo para confirmar una instalación, permite a un atacante introducir un código javascript en las propiedades de un URL, valiéndose de un error de validación en el parámetro "iconURL" en la función "InstallTrigger.install()", la cuál es llamada cuando se instalan extensiones (extension/theme add-ons).

Esto puede ser explotado por una página web o un correo electrónico malicioso, para eludir las restricciones de seguridad e inyectar código JavaScript en el contexto de un archivo "chrome" (este tipo de archivo contiene todas las partes de la interfase de usuario que se encuentran fuera del contenido del área de la ventana, es decir barras de herramientas, menús, barras de progreso y títulos de las ventanas).

El segundo error permite a usuarios maliciosos ejecutar un ataque del tipo "Cross-Site-Scripting", al ser posible inyectar código en un marco (o frame) de una página Web, en el contexto de direcciones ya visitadas y en una etiqueta "IFRAME" (etiqueta que normalmente permite la inclusión de páginas o documentos dentro de otras páginas, ya sean del mismo dominio o no).

Esto puede ser explotado para ejecutar un script dentro de código HTML, en la sesión del usuario actual, y robar cookies u otra información confidencial.

Un sitio web construido maliciosamente, puede eludir las restricciones para ejecutar scripts (archivos de comandos), en ventanas pertenecientes a diferentes dominios. Esto es válido para cualquier sitio web o para un archivo local.

Esta vulnerabilidad puede ser combinada con la primera para ejecutar cualquier otra clase de código.


* Eludir controles de seguridad (javascript)

Referencia: Mozilla Foundation Security Advisory 2005-43

Algunos controles de seguridad creados para prevenir la inyección de código son incorrectos, y podrían ser eludidos envolviendo un url "javascript:" en el seudo protocolo "view-source:".

Una variante del "favicon exploit" de Michael Krax para Firefox, todavía podría utilizarse en Netscape para ejecutar código de forma arbitraria, y la misma técnica se podría emplear para ataques del tipo "Cross-Site-Scripting". Georgi Guninski y L. David Baron, también demostraron fallos similares o relacionados con esta vulnerabilidad.


* Escalada de privilegios (non-DOM)

Referencia: Mozilla Foundation Security Advisory 2005-44

Se agregaron controles adicionales para asegurar que código y objetos script, se ejecuten con los privilegios del contexto en que fueron creados, y no con los del contexto potencialmente superior al que llaman.


Software vulnerable:

- Netscape Browser 8.0
- Netscape Browser 7.x
- Netscape Browser 6.x


Software NO vulnerable:

- Netscape Browser 8.0.1


Solución

Actualizarse a la versión no vulnerable, desde el siguiente enlace:

http://browser.netscape.com/ns8/download/default.jsp

NOTA: Netscape Browser 8.0.1 incluye todos los parches de seguridad de Firefox hasta la versión 1.0.4.


Créditos (originales en Mozilla):

Paul (Greyhats)
Michael Krax, Georgi Guninski, L. David Baron
moz_bug_r_a4


Referencias

FrSIRT/ADV-2005-0583
Netscape Browser Multiple Remote Code Execution Vulnerabilities
http://www.frsirt.com/english/advisories/2005/0583

Netscape Security Alerts
http://browser.netscape.com/ns8/security/alerts.jsp

Mozilla Foundation Security Advisory 2005-42
Title: Code execution via javascript: IconURL
http://www.mozilla.org/security/anno...sa2005-42.html

Mozilla Foundation Security Advisory 2005-43
Title: "Wrapped" javascript: urls bypass security checks
http://www.mozilla.org/security/anno...sa2005-43.html

Mozilla Foundation Security Advisory 2005-44
Title: Privilege escalation via non-DOM property overrides
http://www.mozilla.org/security/anno...sa2005-44.html
Compartir
  #1  
Creado: 23-May-2005, a las 15:03 Vistas: 503
Creado por: W-Bot W-Bot está desconectado (18-February-2005 | Colombia | 5.563 Mensajes.)